HybridAuth's config params correction

Hope can be helpful!
Id and secret of social provider must be in keys array:

From:

    'hybridauth' => [
            'providers' => [
                'google' => [
                    'enabled' => true,
                    'id' => 'YOUR GOOGLE CLIENT ID',
                    'secret' => 'YOUR GOOGLE CLIENT SECRET'
                ],
               // ......

https://api-tools.getlaminas.org/documentation/recipes/integrate-social-logins

To:

    'hybridauth' => [
            'providers' => [
                'google' => [
                    'enabled' => true,
                    'keys' => [ 
                        'id' => 'YOUR GOOGLE CLIENT ID',
                        'secret' => 'YOUR GOOGLE CLIENT SECRET'
                    ],
                ],

@juliangorge
If you found a bug in the documentation please report this problem in the issue tracker of the documentation: https://github.com/laminas-api-tools/documentation/issues

Thanks in advance!

1 Like