Failing to install laminas-api-tools-doctrine-querybuilder


I am trying to install laminas-api-tools-doctrine-querybuilder 1.9.x but it is failing. The installation requires doctrine-module 1.2 || 2.1.8, however, my current laminas project is using doctrine-module 4.0.0. I have tried to downgrade doctrine-module to 2.1.8 but the downgrading also requires that i downgrade doctrine-orm-module.

Is there laminas-api-tools-doctrine-querybuilder that is compatible with doctrine-module 4.0.0? If not is there any package that i can use that will enable me to achieve what i can achieve with laminas-api-tools-doctrine-querybuilder?


What version of PHP are you using?

If you see on Github project “Laminas Doctrine QueryBuilder” v.1.9.0
you can see in composer.json file:

"require": {
      "php": "^7.3 || ~8.0.0",
       "doctrine/doctrine-module": "^2.1.8 || ^3.0.1 || ^4.1.0",

I think you should upgrade doctrine/doctrine-module to 4.1
Otherwise you have to downgrade it to 3.0 or 2.1.8