HTTP ERROR 500 when adding module to modules.config

Hi, I am a student trying to develop this reports and fee system for a Hospital in order to do my thesis, I am just following the tutorial and I don’t know why do I get this error.
I would be very thankful if someone could help me.

I am using the php built in server, and it works fine until i try to add the Album module to the modules.config, and im pretty sure im not commiting any mistakes.

I also get this error on the google chrome console:
crbug/1173575, non-JS module files deprecated.

Hello and welcome to our forums! :smiley:

Please enable development mode for your application otherwise the errors are not visible.
You can use Composer for this:

composer development-enable

The development mode is also described in the tutorial:

https://docs.laminas.dev/tutorials/getting-started/skeleton-application/#development-mode

Hi, thanks for the welcome. As I said, I did follow the tutorial and I am in development mode, this is one of the things I made sure of multiple times. I just redid it just in case and it is still not working.
Thanks in advance! I really appreciate the anwser. Also, I think the error might have to do with this, because I don’t see any errors.
If I could see them, where should they be supposed to be? I would guess in the server logs but it does not say anything else.

First add a new module (e.g. Album) to a file composer.json in the root directory of the application:

"autoload": {
        "psr-4": {
...
	"Album\\": "module/Album/src/"
        }
    },

Afterwards, run the following to update the generated autoloader:

$ composer dump-autoload