Mezzio-swoole project works abnormal when treated as mezzio-no-swoole running on Win10

I am not a smart programmer, not working on MAC or linux desktop system. I just do my job on Windows 10 system. It is very hard to run a swoole on a pure windows 10 system. I dont’t want to run docker or vmware stuff on my work computer, because it makes my computer run as a turtoise!

What I tried that:
Webserver is ubuntu 20.04 with swoole installed and run the mezzio-swoole there. And use jekins to restart the whole stuff.

Locally, I wish to run it as a normal mezzio project with no swoole. When all the debug things done then I upload the codes upto the remote webserver via SVN. then restart it via jekins.

But when I treated it as a normal mezzio, and run it via

php composer.phar run --timeout=86400 serve

it raise erros when visit it in the web browser, like
11111

It is very inconvenient.

Besides, my local enviorment is simple. I download a php.zip from pecl, and unzip it, then add the folder path to win 10 system path. It is not complicat for me.

So my question is, how I run a mezzio-swoole on webserver but deveoping and debuging it in local win 10 without swoole.

No one knows what kind of error you are getting. Please enable the development mode for you application.

In the quick start guide of Mezzio you will find the following:

Development Mode

laminas-development-mode allows you to enable and disable development mode from your cli.

$ composer development-enable  # enable development mode
$ composer development-disable # disable development mode
$ composer development-status  # show development status

The development configuration is set in config/autoload/development.local.php.dist. It also allows you to specify configuration and modules that should only be enabled when in development, and not when in production.

https://docs.mezzio.dev/mezzio/v3/getting-started/quick-start/#development-mode