Build, deploy, not working


First off, hats down for this incredible tool! For what I have used it, on localhost, it’s incredible and so simple to build REST apis!

My issue is… Everything works fine locally. I’m running Laminas on localhost:8081 and the front-end, vus.js, on localhost:8080. After enabling cors, it works just fine.

But now… Heading on the api-admin tool to package the whole in order to upload to my host, well, first off the “generate package” button does nothing but spin, and at some point a toaster pops up telling me the packaging operation was initialized. I try to package with composer install as a zip file. Well, a tool can be broken, so I tried to follow the guide to manually build… Not much luck either, the page just stays… blank… And endpoints return 404, oauth2 (password) endpoint too

Hello and welcome to our forums! :smiley:

Are there any other problems during package creation? Compare with:

I’m sorry, but I don’t use the API tools, so my help is very limited.

Hi and thank you for your fast reply, sorry for my late answer, different timezone (switzerland, currently 5:30 morning) :slight_smile:

This issue worked me up so much that I connected the project at home and tested on my computer, the generate package actually works here. At work, no error in dev console

The difference I can see are, when clicking generate, Edge asks me if I want to leave the page, warning that my unsaved work would be lost. When accepting, the zip file downloads. This never triggers at work on the crap computers, sound a bit like a out of memory thing.

I’ll try the downloaded package and come back to you to clear this topic hopefully (and mark my hours and make them change my computers at work)