Something went wrong while saving this configuration: Class Laminas\Uri\Http does not exist
our php version 7.3.33, Since using Magento 2.3, the highest PHP version it can use is 7.3
cant upgrade the php version
- laminas/laminas-http 2.17.1 requires php ~8.0.0 || ~8.1.0 || ~8.2.0 → your PHP version (7.3.33) does not satisfy that requirement.
- laminas/laminas-http 2.17.0 requires php ~8.0.0 || ~8.1.0 || ~8.2.0 → your PHP version (7.3.33) does not satisfy that requirement.
any fix available for this?
"laminas/laminas-http": "^2" perhaps?
Older versions are no longer actively maintained, but still work just fine.
how to make it work?
i am not a dev
Sorry, but you’ll really need a dev for this stuff :-\
Alternatively, make sure you are on a newer PHP stable version.
If you’re not a developer how you came up with this information? Also, Ocramius has given the answer here and you just need to decrement the value to satisfy your need. Thank!
If using composer, and being sure that all code run properly on php7.3 (albeit being stated otherwise in the packages composer.jsons), you can also try “composer update --ignore-platform-reqs”. This will disregard the php version…
Asgeir: please don’t recommend that, it will just shift the error from installation to runtime. Since the OP is not an experienced developer, you are just throwing them into a world of trouble.
Yeah, sorry, but --ignore-platform-reqs have saved me so many times, I just couldn’t resist…
AND it is easily reversible, since you can just run update again without it…
And I agree on the need to be a developer to do things like this, for sure.